IPV6 LÀ GÌ? CÁCH ĐỔI ĐỊA CHỈ IPV4 SANG IPV6 VÀ NGƯỢC LẠI

  -  


*

IPv6 là gì

Lịch sử Thành lập của IPv6 (trường đoản cú viết tắt của Internet Protocol 6) tương đối lâu. Đó là vào khoảng thời gian 1981, Khi các máy tính xách tay phần nhiều chỉ hoàn toàn có thể truy vấn mạng internet phục vụ cho những tổ chức triển khai nghiên cứu và phân tích quân sự chiến lược. Với môi trường thiên nhiên thao tác 8 bit, kết phù hợp với không khí liên tưởng 32 bit vày phiên bạn dạng Internet Protocol 4 (viết tắt là IPv4) hỗ trợ có thể chấp nhận được liên kết cho tới 4 tỷ liên can khác biệt. 

Trải qua ngay gần 30 năm, sự trở nên tân tiến của công nghệ đang chế tác bước nâng tầm, mạng internet trường thọ bên trên mọi thế giới khiến cho số lượng ảnh hưởng đã gần tới cả cực đại. Đồng thời, nó còn dự báo hiện đang có thể vượt giới hạn của IPv4. Về kim chỉ nan, ví như quá nút trằn thì năng lực kết nối internet sẽ không còn thể hoạt động được. Chính điều này đã tạo động lực thúc đẩy việc phân tích, cách tân và phát triển giao thức mới, góp hạn chế yếu điểm bên trên.

Bạn đang xem: Ipv6 là gì? cách đổi địa chỉ ipv4 sang ipv6 và ngược lại

Đầu trong thời gian 1990, IETF cải cách và phát triển một giao thức mới mang tên Gọi là IP.. Next Generation (IPng). Và vào thời điểm năm 1998, giao thức này bằng lòng chuẩn chỉnh hóa, được Tổng đơn vị Internet cho tên miền và số (viết tắt là ICANN) phê coi ngó, cho phép áp dụng bên trên rộng thoải mái trên thế giới. Giao thức được lấy tên IPv6 (RFC 1883).

IPv6 thành lập và hoạt động đang xử lý được số đông hạn chế sống thọ của IPv4 trong khối hệ thống mạng internet, tạo nên bước tiến nhảy vọt của công nghệ số.

Các điểm cải tiến của IPv6 so với IPv4:

Không gian tàng trữ mập. IPv4 gồm không khí truy vấn 32 bit, tương tự 4 tỷ ảnh hưởng. Còn IPv6 có không khí là 128 bit, to hơn vội 4 lần so với IPv4. Độ bảo mật thông tin cao hơn. Khả năng định tuyến đường được tăng vọt. Cấu hình được thiết kế với theo hướng dễ dàng hơn so với IPv4.

Lợi ích của IPv6 connectivity

Các công dụng mà lại IPv6 đang với sẽ đem đến cho người dùng kia là:

Cho phnghiền không gian tác động phệ, góp câu hỏi cai quản không gian này trnghỉ ngơi cần tiện lợi hơn. Quản trị dễ ợt rộng. Do IPv6 có công dụng auto thông số kỹ thuật nhưng ko bắt buộc mang lại sever DHCP.. Trong khi ấy, IPv4 đề xuất DHCPhường. để cấu hình. Định đường IPv6 được thiết kế theo phong cách phân cung cấp phải cấu trúc xuất sắc. IPv6 hỗ trợ giỏi hơn về Multicast. Việc sắp xếp cùng format header được triển khai công nghệ và tối ưu giúp bài toán bảo mật thông tin thông báo được đổi mới rộng. IPv6 cung cấp giỏi cho những thiết bị di động cầm tay.

Cấu trúc xúc tiến IPv6

Cấu trúc của IPv6

Cấu trúc của một IPv6 bao gồm 128 bit, được tạo thành 8 nhóm. Trong số đó, mỗi đội tất cả 16 bit với được phân loại vì vệt “:”.

Một ảnh hưởng IPv6 được trình bày theo cấu trúc sau:

FEDC:BA98:768A:0C98:FEBA:CB87:7678:1111:1080:0000:0000:0070:0000:0989:CB45:345F

Vì cấu trúc quá dài cần người ta thường xuyên quăng quật số 0 làm việc đầu mỗi team nhằm rút gọn. Đối cùng với đội như thế nào chỉ bao gồm tốt nhất dãy số 0 thì nó sẽ được biểu diễn bằng lốt “::”

*

Cấu trúc của Address Prefixes

Address Prefixes có cấu trúc giống như IPv4 CIDR. Cách bộc lộ của nó là IPv6-address/ prefix-length. 

Trong đó:

- IPv6-address: Địa chỉ IPv6 với giá trị bất kỳ.

- Prefix-length: Số bit gần kề nhau trong prefix.

Ví dụ: Quy tắc màn biểu diễn của 56 bit prefix 200F00000000AB là

200F::AB00:0:0:0:0/56

200F:0:0:AB00::/56

Lưu ý: Với ảnh hưởng IPv6, kí hiệu “::” chỉ được sử dụng độc nhất vô nhị 1 lần trong một sự màn trình diễn.

Các thành phần của IPv6

Địa chỉ IPv6 tất cả 3 thành phần: site prefix, subnet ID và interface ID. Trong đó:

Site prefix: Đây là thông số được gán cùng với trang web trải qua ISP.. Do đó, toàn bộ máy tính ở cùng vị trí sẽ share cùng nhau bằng một site prefix. Có thể thấy, đặc tính của site prefix là khi đã nhận ra mạng của người tiêu dùng với chất nhận được truy cập trải qua mạng internet thì nó vẫn đào bới vấn đề sử dụng bình thường. Subnet ID: Đây là yếu tắc bên phía trong trang web. Nó được dùng để làm mô tả cấu tạo site của mạng. Vì nuốm, một IPv6 subnet sẽ sở hữu kết cấu tương tự một nhánh mạng 1-1. Interface ID: Cấu trúc của chính nó tương tự như ID trong IPv4. Các thông số kỹ thuật vẫn nhấn dạng một host riêng. Interface ID có thông số kỹ thuật tự động hóa. 

Ví dụ: Địa chỉ IPv6 gồm cấu trúc: 2001:0f68:0000:0000:0000:0000:1986:69af bao gồm:

- Site prefix: 2001:0f68:0000

- Subnet ID: 0000

- Interface ID: 0000:0000:1986:69af
*

Phân một số loại địa chỉ IPv6 connectivity

Có 3 loại hệ trọng IPv6:

Unicast: Một can hệ Unicast được hướng đẫn riêng biệt cho 1 cổng của node IPv6. Lúc bao gồm một gói tin gửi mang đến thúc đẩy Unicast, nó sẽ được mang lại cổng đã chỉ định bởi vì hệ trọng đó. Multicast: Đây là nhóm những cổng IPv6. lúc một gói tin gửi mang lại tương tác Multicast thì nó sẽ được toàn bộ thành viên trong team multicast giải pháp xử lý. Anycast: Đây là can hệ đăng ký cho nhiều cổng (tức bên trên những node). lúc tất cả gói tin gửi cho tác động Anycast, nó sẽ tiến hành đưa cho một cổng bất kỳ, mặc dù, phần nhiều là mang lại cổng gần nhất.

Hướng dẫn giải pháp đặt địa chỉ IPv6 cho win 7, 8, 10

Để đặt tương tác Ipv6 cho win 7, 8, 10, chúng ta tiến hành nhỏng sau:

Cách 1: Clichồng vào biểu tượng Window, chọn tiếp Run. Trong hành lang cửa số Run, nhập loại chữ ncpage authority.cpl. Cách 2: Bạn chọn card mạng mong mỏi gán IPv6, kế tiếp chọn tiếp Properties. Cách 3: Tiếp tục chọn Internet Protocol Version 6 (TCP/IPv6), rồi lựa chọn Properties.
*
Bước 4: Quý khách hàng triển khai điền các thông số giá trị IPv6 ở trong phòng cung cấp (tìm hiểu thêm hình bên dưới). 
*
Cách 5: Sử dụng câu lệnh ipconfig sống cmd để tiến hành ping bình chọn hiệu quả IPv6. Bằng phương pháp, mngơi nghỉ cmd, gõ tiếp lệnh ipconfig. Lúc này, một hành lang cửa số hiển thị như hình sau.
*

Kế mang đến, thực hiện loại lệnh ping -6 ipv6.google.com để bình chọn IPv6:

*

Nếu khối hệ thống hiển thị hiệu quả trả lời Có nghĩa là chúng ta đang thiết lập thành công xuất sắc thúc đẩy IPv6.

Hướng dẫn giải pháp áp dụng IPv6 - đặt hệ trọng IPv6 trải qua Remote UI

Các làm việc thực hiện đặt thúc đẩy IPv6 bằng phương pháp thực hiện Remote UI được tiến hành nhỏng sau:

Cách 1: Quý khách hàng khởi động Remote UI và đăng nhập lệ khối hệ thống. Bước 2: Cliông chồng chọn tlỗi mục Setting/Registration nghỉ ngơi cột bên nên như hình sau.
*
Cách 3: Trong bảng hiển thị, cliông chồng lựa chọn Network Setting, rồi chọn tiếp TCP/ IP Settings.
*
Bước 4: Tại mục IPv6 Setting, các bạn click lựa chọn Exit.
*
Cách 5: Hiện nay một bảng thoại lộ diện. quý khách lựa chọn vỏ hộp bình chọn rồi thực hiện cấu hình cài đặt.
*
Cách 6: lúc đang hoàn tất thiết đặt ở bước 5, chúng ta cliông chồng OK nhằm chấm dứt thiết lập IPv6.

Cấu hình IPv6 bên trên Router Cisco

Các bước tiến hành như sau:

Cách 1: Tiến hành cấu hình IPv4, giao thức OSPFv2 trên những Router Thename cùng Thename1. Đây là những thương hiệu router mang định nhưng Hosting Việt đặt đến ví dụ minc họa sau nhằm bạn dễ dàng nắm bắt. Trong thực tiễn, chúng ta có thể đánh tên tùy ý theo yêu cầu thực hiện.

- Thename: 

Cú pháp câu lệnh thực hiện:

Thename#config terminal

Thename(Config)#interface fastethernet 0/0

Thename(Config-if)#ip address 192.168.12.1 255.255.255.0

Thename(Config-if)#no shut

Thename(Config-if)#interface loopback 0

Thename(Config-if)#ip address 1.1.1.1 255.255.255.255

Thename(Config-if)#no shut

Thename(Config-if)#interface fastethernet 0/1

Thename(Config-if)#no ip address

Thename(Config-if)#ipv6 enable

Thename(Config-if)#ipv6 address 2000::1/64

Thename(Config-if)#no shut

Thename(Config-if)#exit

Thename(Config)#router ospf 100

Thename(Config-router)#network 1.1.1.1 0.0.0.0 area 0

Thename(Config-router)#network 192.168.12.0 0.0.0.255 area 0

- Trên ISP:

Cú pháp câu lệnh:

ISP#config terminal

ISP(Config)#interface fastethernet 0/0

ISP(Config-if)#ip address 192.168.12.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#interface fastethernet 0/1

ISP(Config-if)#ip address 192.168.23.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#exitISP(Config)#router ospf 100

ISP(Config-router)#network 192.168.12.0 0.0.0.255 area 0

ISP(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Hình sau là bảng định tuyến đường IPv4 trên Thename.

Xem thêm: Game Tiến Lên Kiểu Chơi Miền Nam Đếm Lá, Chơi Game Tiến Lên Miền Nam Đếm Lá

*

- Thename1

Cú pháp câu lệnh:

Thename1#config terminal

Thename1(Config)#interface fastethernet 0/0

Thename1(Config-if)#ip address 192.168.23.3 255.255.255.0

Thename1(Config-if)#no shut

Thename1(Config-if)#exit

Thename1(Config)#router ospf 100

Thename1(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Dưới đó là bảng định đường IPv4 bên trên Thename1.

*

Hiện nay, những mạng IPv4 vẫn rất có thể thấy với liên kết cùng nhau.

Bước 2: Tạo interface tunnel 0 bên trên Thename với Thename1 

- Thename

Câu lệnh:

Thename(config)#ipv6 unicast-routing

Thename(config)#interface tunnel 0

Thename(config-if)#ipv6 address 3000::1/64 eui-64

Thename(config-if)#no ipv6 nd suppress-ra

Thename(config-if)#tunnel source loopback 0

Thename(config-if)#tunnel mode ipv6ip isatap

Để kiểm tra Tunnel vừa tạo thành, chúng ta cần sử dụng lệnh show ipv6 interface brief.

*

Theo hình bên trên, Thename bao gồm tương tác IPv6 của tunnel 0 là 3000::5EFE:101:101

- Thename1:

Cú pháp câu lệnh nlỗi sau:

Thename1(Config)#interface tunnel 0

Thename1(Config-if)#ipv6 enable

Thename1(Config-if)#ipv6 address autoconfig

Thename1(Config-if)#tunnel mode ipv6ip

Thename1(Config-if)#tunnel source fastethernet 0/0

Thename1(Config-if)#tunnel destination 1.1.1.1

Để chất vấn tunnel 0 vừa tạo, chúng ta cũng tiến hành câu lệnh giống như nhỏng bên trên là dùng lệnh show ipv6 interface brief.

*

Theo bảng trên, can dự IPv6 của tunnel0 trên Thenamemột là 3000::C0A8:1703

Bước 3: Thực hiện định tuyến tĩnh bên trên những router IPv6 để các mạng con thấy nhau, bằng cách dùng câu lệnh ipv6 route x:x:x:x::x/ next-hop hoặc interface.

- Thename: Thename(config)#ipv6 route 4000::/64 3000::c0a8:1703

- Thename1: Thename1(config)#ipv6 route 2000::/64 3000::5efe:101:101

Sau đó, bạn đánh giá những bảng định con đường.

Hình sau là bảng định tuyến đường IPv6 trên Thename.

*

Dưới đây là bảng định tuyến IPv6 bên trên Thename1.

*

Cách 4: Thực hiện setup IPv6 cho những host với ping nhằm khám nghiệm kết nối

Cách thực hiện nlỗi sau:

- Đặt IPv6 mang đến máy tính thực hiện Window Vista, 7, 8, 10, chúng ta tiến hành nlỗi trả lời giải pháp đặt liên tưởng IPv6 làm việc mục trên. Đó là vào Start / chọn Control panel / lựa chọn tiếp Network and Internet / clichồng lựa chọn Network and Sharing Center /click mục Change adapter setting / và lựa chọn Properties Local Area Connection / tiếp nối, click vào Internet Protocol Version 6 để cài đặt cửa hàng IPv6.

Xem thêm: Chụp Ảnh Tự Sướng Là Gì - Chụp Ảnh Selfie Tự Sướng Là Gì

Đặt IPv6 mang lại laptop áp dụng Window XP: Clichồng vào nút Start / gõ Cmd trong tkhô nóng tìm kiếm tìm / kích hoạt bản lĩnh IPv6 bằng phương pháp gõ câu lệnh “netsh interface ipv6 install”. Sau đó, dùng tiếp lệnh “netsh interface ipv6 add address “Local Area Connection” 2000::2/64” để tại vị shop IPv6.
*

Sau khi hoàn chỉnh đặt cửa hàng IPv6 mang lại host, các bạn thực hiện ping nhằm đánh giá kết nối:

- Kiểm tra liên kết trường đoản cú host 1 cho host 2

*

- Kiểm tra kết nối chiều ngược chở lại tự host 2 mang lại 1

*

Lúc này, 2 host đang thấy nhau. Đây là hướng dẫn về kiểu cách sử dụng hình thức ISATAPhường. tùy chỉnh cấu hình kết nối của IPv6 là gì. Mô hình mạng này tương đối đơn giản cùng chúng ta dễ dãi không ngừng mở rộng với nhiều router khác nhau, kết hợp áp dụng định tuyến thời thượng hơn.

Bên cạnh đó, chúng ta cũng bắt buộc để ý là trước khi sử dụng ping để kiểm soát kết nối, bạn đề nghị đảm bảo an toàn Window Firewall đã làm được tắt.